Vagrant up now bringing up VM

I am been have been stock with vagrant up for a couple of days, now, I install the latest vagrant and VM Box, but each time I run the vagrant up command I get the below error, I have uninstall vagrant and reinstall but the issue persist, my anti-virus and firewall are all turn off still no headway.

USER@DESKTOP-EHQ5KSP MINGW64 ~/f/vagrant-vms/centos7
$ vagrant up
Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Box ‘geerlingguy/centos7’ could not be found. Attempting to find and install…
default: Box Provider: virtualbox
default: Box Version: >= 0
==> default: Loading metadata for box ‘geerlingguy/centos7’
default: URL: https://vagrantcloud.com/geerlingguy/centos7
==> default: Adding box ‘geerlingguy/centos7’ (v1.2.26) for provider: virtualbox
default: Downloading: https://vagrantcloud.com/geerlingguy/boxes/centos7/versions/1.2.26/providers/virtualbox.box
default:
An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.

penSSL SSL_read: Connection was reset, errno 10054

Kindly help, I could not continue with what I am doing because of this challenge with vagrant up command

Make sure you are running vagrant up from the correct directory vagrant-env