Vagrant up error with ubuntu site... maybe

using windows 10 when I run vagrant up the system returns:
mongod-m103: + echo ' localhost localhost.localdomain localhost4 localhost4.localdomain4 ’
mongod-m103: + echo ‘::1 localhost localhost.localdomain localhost6 localhost6.localdomain6’
mongod-m103: + echo ‘fe00::0 ip6-localnet’
mongod-m103: + echo ‘ff00::0 ip6-mcastprefix’
mongod-m103: + echo ‘ff02::1 ip6-allnodes’
mongod-m103: + echo ‘ff02::2 ip6-allrouters’
mongod-m103: + echo ‘ff02::3 ip6-allhosts’
mongod-m103: + echo ‘ m103 m103’
mongod-m103: + update_repo
mongod-m103: + echo ‘Install MongoDB Enterprise Repository’
mongod-m103: Install MongoDB Enterprise Repository
mongod-m103: + echo ‘deb [ arch=amd64 ] trusty/mongodb-enterprise/3.6 multiverse’
mongod-m103: + sudo tee /etc/apt/sources.list.d/mongodb-enterprise.list
mongod-m103: deb [ arch=amd64 ] trusty/mongodb-enterprise/3.6 multiverse
mongod-m103: + sudo apt-key adv --keyserver --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.gB5oqYd8xs --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/ubuntu-advantage-esm-infra-trusty.gpg --keyserver --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: gpg:
mongod-m103: requesting key A15703C6 from hkp server
mongod-m103: ?:
mongod-m103: Connection refused
mongod-m103: gpgkeys: HTTP fetch error 7: couldn’t connect: Connection refused
mongod-m103: gpg:
mongod-m103: no valid OpenPGP data found.
mongod-m103: gpg:
mongod-m103: Total number processed: 0
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Anyone with same error and a solution?

Thanks in advance.


Hi @AndreaBellini_75644,

Are you connected to any Corporate/VPN network ?

Please make the change mentioned below in your provision-mongod file.

sudo apt-key adv --keyserver --recv 0C49F3730359A14518585931BC711F9BA15703C6


sudo apt-key adv --keyserver hkp:// --recv 0C49F3730359A14518585931BC711F9BA15703C6

If the issue still persists then I would recommend you to try to connect from some other network before running the vagrant up command.

Hope it helps!

Please feel free to get back to us if the issue still persists.

Happy Learning :slight_smile:

Shubham Ranjan
Curriculum Support Engineer

This solved my problem. Thanks.

Hi @AndreaBellini_75644,

I’m glad your issue got resolved. Please feel free to create another thread if you have any other query.

Shubham Ranjan
Curriculum Services Engineer

Closing the thread as the issue has been resolved.