Vagrant Up Error Windows 10 [Needs Help]

Hi All,
vagrant up command is throwing the following error:

==> mongod-m103: Booting VM…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “83e99304-65f8-435d-8b48-060b80b8fad9”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: The virtual machine ‘mongod-m103’ has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in ‘C:\Users\shankar.k\VirtualBox VMs\mongod-m103\Logs\VBoxHardening.log’
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component MachineWrap, interface IMachine

Hyper-V is disabled in my win10 where as virtualization is enabled in BIOS.

The version I use are:

Virtual Box - 6.0.10
Vagrant - 2.2.5

I’ve re-installed the above versions as well as tried earlier versions of the above software to no avail.

Last few lines of hardening log are given below:

6034.1698: supR3HardenedWinInitAppBin(0x0): ‘\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox’
6034.1698: Calling main()
6034.1698: SUPR3HardenedMain: pszProgName=VBoxHeadless fFlags=0x0
6034.1698: supR3HardenedWinInitAppBin(0x0): ‘\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox’
6034.1698: ‘\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VBoxHeadless.exe’ has no imports
6034.1698: supHardenedWinVerifyImageByHandle: -> 24202 (\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VBoxHeadless.exe)
6034.1698: SUPR3HardenedMain: Respawn #2
6034.1698: Error (rc=-5640):
6034.1698: More than one thread in process
6034.1698: Error -5640 in supR3HardenedWinReSpawn! (enmWhat=1)
6034.1698: More than one thread in process
5fc4.100: supR3HardNtChildWaitFor[1]: Quitting: ExitCode=0x1 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 98 ms, the end);

Request support in resolution.

Hey @SHANKAR_45289

Some post I found that may help you

Hope these help. Report back if not.

yeah, had a look. These didn’t help. Thanks for helping.

And I will guess that you have tried to start over with

vagrant destroy
vagrant up

Yes, tried that as well. Same error though.

I have an issue with vagrant

C:/HashiCorp/Vagrant/embedded/gems/2.2.5/gems/vagrant-2.2.5/lib/vagrant/bundler.rb:54:in []=': Invalid C:/HashiCorp/Vagrant/embedded/gems/2.2.5/gems/vagrant-2.2.5/lib/vagrant/bundler.rb:54:in=’: Invalid argument - ruby_setenv(GEMRC) (Errno::EINVAL)
from C:/HashiCorp/Vagrant/embedded/gems/2.2.5/gems/vagrant-2.2.5/lib/vagrant/bundler.rb:54:in initialize' from C:/HashiCorp/Vagrant/embedded/gems/2.2.5/gems/vagrant-2.2.5/lib/vagrant/bundler.rb:32:innew’
from C:/HashiCorp/Vagrant/embedded/gems/2.2.5/gems/vagrant-2.2.5/lib/vagrant/bundler.rb:32:in instance' from C:/HashiCorp/Vagrant/embedded/gems/2.2.5/gems/vagrant-2.2.5/bin/vagrant:95:in

@Kanika & @Shubham_13709 Are there any other options to learn and do this course M103 without using vagrant?

I’ve spent most of my time since 20th and not sure how to go forward.


I hope someone can help you find a solution. However I do believe this is the hardest course to run without the vagrant or some sort of containment.

Yeah, hope/pray there is some solution to this mess called vagrant. Have already installed MongoDB community 4.0.5. Can’t it or the Atlas free tier serve the purpose?

Hi @SHANKAR_45289,

I hope you were able to resolve vagrant issue as you have already completed Chapter 1 in M103 :clap:

Please let me know, if you have any questions.


Hi @Dzmitry_Boichanka_39791,

Please try solution mentioned in the following link:

Please share the complete error message that you see and also share the specifications of the system that you are using.

Let me know, if you have any questions.


Me too Struggling with Vagrant and was unable to do M103 due to it and now facing same issue for M402

Hi @purva130,

I am sorry to hear that you were not able to continue with M103 due to vagrant issue.

Can you please share the following details so that I can help you in fixing the issue and getting you all set if you ever plan to take the course again ?

  • Name and the version of the host operating system
  • Version of the Virtual box and the vagrant
  • Output of the vagrant up command.

Shubham Ranjan
Curriculum Support Engineer

Hi Shubham,
vagrant version - 2.2.6
oracle virtual box version - 6.0.14
Windows 10 home
please find screenshot of error

I am getting

Virtualisation is already enabled.Tried restarting system many times.Uninstalled and reinstallation also tried many times. Nothing working

Hi @purva130,

For this error, since virtualization is already enabled as you have mentioned, please make sure you have Hyper-V turned off in Windows 10.

For Windows 10:

Press Windows key.
Type “Turn Windows features on or off”
Deselect the checkbox next to Hyper-V.
Select OK.
Select Restart now.

Let me know if this helps! :slight_smile:


There is no HyperV option present over there.
Disable hyperv manually as well by using dism.exe and restarted system
Still same issue

Was there any recent update to your Windows home?

Try to disable memory integration
Since you tried all and nothing works please try fresh install in C Drive

1 Like