Vagrant not found in MacOS

Hi… I am using Mac. Just installed Virtual Box and Vagrant. Virtual Box is available in application list but not vagrant. While following second video in this training, i am unable to copy vagrant related files to /university/m103 directory as i don’t have m103-vagrant-env directory anywhere on my machine. However, still i tried to use “vagrant up” command, hoping that it can do something but it failed with below error. Please help with it as i won’t be able to continue with lectures without having it setup.

----------ERROR BELOW----------
A Vagrant environment or target machine is required to run this
command. Run vagrant init to create a new Vagrant environment. Or,
get an ID of a target machine from vagrant global-status to run
this command on. A final option is to change to a directory with a
Vagrantfile and to try again.


same problem here.
it says the following:
cp: m103-vagrant-env/: No such file or directory

Please make sure that your “university” directory is not in root. Try to create directories with “mkdir -p ~/university/m103” command.

Sir @jveeru, I run the command mkdir -p ~/university/m103 on my desktop and created the directory.
But I’m getting the same error trying to run the cp -r m103-vagrant-env/ ~/university/m103/

Do I have to go to then vagrant directory to run this command? If so, where I can find the vagrant directory?
thank you sir

He there @Agner_09923,

Thanks for replying. So the problem that I can think of is that you probably are not in same directory as your ‘m103-vagrant-env’ directory. I am using Mac and I dowloaded zip file and it was saved in my “Downloads” folder. I then opened the folder and unzipped it. Using my terminal, I did “cd Downloads/” and than I ran the command to copy contents from m103-vagrant-env to m103.

So basically you want to be in a directory where your m103-vagrant-env folder is. Try this and let me know if it doesn’t work.

the vagrant command need to be run from the folder where the Vagrantfile is located as it contains the settings needed to launch the session.

The simplest solution I found was to download the handout, unzip it, then CD to that folder which is the m103-vagrant-env folder, similar to what @jveeru suggested.


thank you sir.
I downloaded the zip and was able to proceed with the instalation.

1 Like

Awesome! happy to help :smiley:


Thanks guys. I was able to work. Actually mistake was from my end. I did not see files in handout and could not figure out that where to get those files from and thought that these comes with vagrant setup itself. After checking here and there, i finally got to know that i should have waited for lecture to finish. Thanks for replies though.