Vagrant hung at mongod-m103: SSH auth method: private key


I am trying to start vagrant but it get hung at SSH auth method step
PS K:\m103-vagrant-env_2> vagrant up --provider virtualbox
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Clearing any previously set forwarded ports…
==> mongod-m103: Clearing any previously set network interfaces…
==> mongod-m103: Preparing network interfaces based on configuration…
mongod-m103: Adapter 1: nat
mongod-m103: Adapter 2: hostonly
==> mongod-m103: Forwarding ports…
mongod-m103: 22 (guest) => 2222 (host) (adapter 1)
==> mongod-m103: Running ‘pre-boot’ VM customizations…
==> mongod-m103: Booting VM…
==> mongod-m103: Waiting for machine to boot. This may take a few minutes…
mongod-m103: SSH address:
mongod-m103: SSH username: vagrant
mongod-m103: SSH auth method: private key

I am getting below error in VM log.Attached is the error scrrenshot.
I have already destory the vagrant and started again with new vagrant but still same issue

Hi @Ashish_85066,

Kindly take a look at the following thread for reference and please let me know if the issue persists.

Hope it helps!

Muskan ,
Curriculum Support Engineer

Thanks for the help.I already tried those steps.Still getting same error

Hi @Ashish_85066,

Can you please try the below steps and let us know if it works for you?

  1. Download the latest versions of vagrant and virtual box.
  2. Update the powershell using the instructions here:
  3. Enable the virtualization in the BIOS

Curriculum Support Engineer

Hi @Ashish_85066,

Please check for following things:

  • Please try to create m103 folder in the user directory.
  • Then extract and save save the folder in the m103 directory.
  • From within the m103-vagrant-env directory, run the following commands:

    vagrant up --provision
    vagrant ssh

Please refer to the VirtualBox&Vagrant_Windows.pdf document attached as Handouts in the Lecture: Setting up the Vagrant Environment for more details.

You can also refer to the following link to resolve the error you are getting:

Please let me know, if you have any questions.