Vagrant failed to initialize at a very early stage

@Shubham_Ranjan , Hi. I have also a problem after I am running the commnd


Please help.

@Semion_79117,

Although your error message mentions not having Read/Write permissions on the “.vagrant” folder, it’s actually indicating that you don’t have the correct permissions on the m103-vagrant-env folder.

You need to give yourself Modify permissions on the m103-vagrant-env folder.

PS: Your error message is slightly different from the original post. In cases like this, it’s best to create your own thread; especially if the thread is old and owned by someone else.

1 Like

Hi @Semion_79117,

Please follow the instructions mentioned by @007_jb in the previous post. Let us know if the issue still persists.

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Although there’s been no confirmation, I think @Semion_79117 has moved on from this and is now faced with a different error message hence his posts in a different thread which you’ll soon get to.

1 Like

Hi, I don`t know how to do it. I just delete the folder and did a new one in another place. so, sorry for no conformation.

There’s a permissions issue on your machine. It’s probably what’s causing the problems in your other thread. Anyway, continue on the other thread.

I dont see a permission issue in my new thread. And I dont see any help in my new thread.

The other thread:
https://www.mongodb.com/community/forums/t/cannot-start-vagrant/2054/36

I tride first with VirtualBox-6.1.2-135663-Win, then with VirtualBox-6.0.14-133895-Win. Then again with VirtualBox-6.1.2-135663-Win when the VBox-Win10-fix-14040 run on backround. But nothing help.

I am not sure about Admin rights. This is my computer, but I dot know how to check what rights I have.


Here I am trying again.

By the way, what is this?
image

I don`t know. I found somewhere in yours forum information and I though it can help to resolve my problem. I am already one week on the same point and nobody know how to help. So I am trying to find any solution.

This VBox ticket is 5 years old and it’s related to the host-onlyif error. Suggest you uninstall it.

Continue in the other thread.

PS: I took this course a while ago so I’m just trying to help you out. I don’t work for MongoDB :slight_smile: And if you had posted a week ago, then it would have most likely have been resolved by now.

1 Like

Thank you very much for your help.
I don’t think that it installed. I look like running on background only when you run the file. I will continue to look for a solution. Thank you one more time.

No problem! Continue the discussion on the other thread.

Hi. I find this topic with exactly the same problem I have. I did all yours recomendation, and this what I have now.


Please help

@kanikasingla
Hi. I did the steps:Make sure you have Hyper-V turned off in Windows 10 For Windows 10: Press Windows key. Type “Turn Windows features on or off” Deselect checkbox next to Hyper-V. Select OK. Select Restart now. still have a problem after restart.

Maybe I need also the step: to Enable virtualization in the BIOS, but I don`t know how to do it.

This what I did to check the BIOS


Next step I reinstall the VirtualBox-6.0.14-133895-Win and install VirtualBox-6.1.2-135663-Win
Same problem

@007_jb , @Shubham_Ranjan
I did the steps, still same problem


And I dont understand, how we can make the m103 by the due date if we cant start it yet?

Potentially an incomplete VirtualBox installation. Do you have Admin rights on your machine? And what are your versions of VirtualBox and vagrant?

I tried first with VirtualBox-6.1.2-135663-Win. Then with VirtualBox-6.0.14-133895-Win. Then again with VirtualBox-6.1.2-135663-Win, that what I have now.
I am not sure about Admin rights. This is my computer, but I dont know how to check what rigths I have.

I’ve just seen in your other thread that you have Admin rights. So the problem could be one of two things:

  1. there were VirtualBox components that didn’t install
  2. your Anti Virus blocked the installation of some of the components and/or is blocking vagrant up

Can you try the following:

  1. Delete the mongod-m103 box:
    vagrant destroy -f
  2. Uninstall VirtualBox
  3. Turn off Anti Virus, Firewall, any other anti-virus/malware type apps like Windows Defender or the one that came with your laptop
  4. Install VirtualBox
  5. Run vagrant up