Vagrant 2.2.6 does not support VirtualBox 6.1.0

Hello everyone,

First, I really like Mongodb University - best and fastest way to get on the saddle, imo.

I am trying to set myself up for M103, and I think I have run in some issues which I am not sure how to solve.

  • I am on Ubuntu 18.04.
  • I have installed VirtualBox 6.1.0
  • I have installed Vagrant 2.2.6
  • From the /m103/m103-vagrant-env folder, I run “vagrant up --provision”
    => I get an error message which starts with “No usable default provider could be found for your system.” and goes on to explain that it needs a “provider”, such as VirtualBox, and suggests to run “vagrant up --provider=virtualbox”
    • I run “vagrant up --provider=virtualbox”
      => I get an error message explaining that Vagrant supports VirtualBox version up to 6.0

I could uninstall virtualbox 6.1 and install 6.0, but I am not sure where to find it.
Could anyone please point me to a place where I can get it, or to another way to get out of this situation?

Thank you very much for your help

Hi @marc-depret,

You can use the below link to download 6.0 version.

Thank you so much :slight_smile: Good luck for the course.


Hi Kanika
Thank you very much for the prompt response.
It worked like a charm and I am now up and running - I can SSH into the virtual machine, which seems to be Ubuntu 14.04.6 LTS.
Forward and upward!

Hi @marc-depret,

I’m glad your issue got resolved. If you have any other query then please feel free to create another thread.

Shubham Ranjan
Curriculum Support Engineer