User is not allowed to do action [getLog] on [admin.]

Hi, I am getting below error and warning,any suggestions?
WARNING: shell and server versions do not match
Error while trying to show server startup warnings: user is not allowed to do action [getLog] on [admin.]

I changed the user role to atlasAdmin

5 Likes

Was the issue resolved after changing the user role to atlasAdmin?

I guess the version which you had downloaded will be version 4 and on the Atlas Cluster it will be at lower version which caused the error.

I have faced the same problem, and it was fix when I changed the role to atlasAdmin. Thank you for the support.

com.mongodb.MongoQueryException: Query failed with error code 8000 and error message ‘user is not allowed to do action [find] on [mflix.movies]’ on server mflix-shard-00-01-tkukw.mongodb.net:27017

Facing this issue. Tried so many things, but still not working.

Hi Suraj_69094,

Please share the post in M220J discussions.

Kanika

Please check for roles on user m220student. User should have readWrite on any database using Atlas.

Kanika