User is not allowed to do action [getLog] on [admin.] MacOS

Hi all,
I tried to follow the lesson and steps, but I still get this in my terminal. “user is not allowed to do action [getLog] on [admin.]”
I did change the role to write and read any database , and I did allow user to connect from anywhere. However, I still get this message every time I try. My version is 4.0.10.
Send help please. Thank you!

i am getting the same error in windows10OS

Hey @Pei_Fong_14092 & @raushankumar248

Are you still getting connected though? Or not at all? I ask because when I connect to my cluster that I used to finish the course, I get the same message. Which is from the fact that the user that was created does not have the permission to run getlog against the admin db; it only has readWrite permissions on all dbs.

getLog is an administrative command that returns…

To be able to run the getLog command it looks to me as if you need to give the user the clusterMonitor role, or one that includes that role.

Here can see what the readWrtieAnyDatabase role includes; which does not list clusterMonitor

With the readWriteAnyDatabase permission you should be able to complete the Course and the labs. As this other student did.

Hope this helps clear things up

Hi @raushankumar248, @Pei_Fong_14092,

You can safely ignore this error message.

If you face any other issue, feel free to get back to us. Happy Learning :slight_smile:

Shubham Ranjan
Curriculum Support Engineer

1 Like

Thanks for explaining this to me. This clear things up.

Alright, thanks you so much!