Unrecognized option : storage

i wrote the configurartion file …but im getting the error
unrecognized option : storage
but there’s actually a path in the in browser ide “/data/db” which i have specified
anybody help to mitigate this error
so i tried to comment out the storage section…but then i got the same error in the next section
unrecognized option : systemLog
please help with my codemongo1

YAML is picky, too picky to my liking. You need a space after the colon (:) when a value is specified.

For example:


should be

dbPath: "/data/db"

Some YAML resources:

thanks for ur help !! ur suggestion worked out well , but again i got some error and the documentation of yaml which u provided was quiet useful and gave the solution that i shouldn’t use tabs for indentation …now the syntax became error free but im getting an global initialization error again :pensive:

Simply share a screenshot of the what you are doing that shows the error you are getting.

1 Like

Hi @Shrikar_Man,

Please share the information requested by @steevej-1495 if you are still facing any issues.

~ Shubham