Uncaught exception

Did anyone get this error at the mongodump command used in the lecture?
SyntaxError: Missing semicolon. (1:12)

Share the command you used or screenshot
Make sure you run the command at os promt

I also got the same error message


Would you please help me check it

You have to exit mongo shell.

mongodump is a command that you issue at your terminal prompt.

1 Like

Hi @Trung_Tran_The, welcome to the community. :wave:
Please remove the whitespace between -- & uri.
It should be:

mongodump --uri “<–Paste-your-connection-string-here–>”

I hope it helps.

In case you have any doubts, please feel free to reach out to us.

Thanks and Regards.
Sourabh Bagrecha,
Curriculum Services Engineer

1 Like

Thanks Steeve but can you give more instructions?

I tried but it still doesn’t work.

Please exit from mongo shell and run the command from os prompt (#,$ etc)

1 Like

You did exactly the same thing as in your first screenshot.

You entered the command while in the mongosh.

You have to exit before entering the command.

2 Likes

Thanks Ranmachandra and Steeve so much.
I got your point, i dit it.

Ps: I have to install “Database Tools MSI installer” and run it with Command Prompt on windows 10

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.