Unable to understand the installation process

Hi Team,

I am using Windows 10 64-bit version.

I have downloaded Virtual Box and Vagrant for Windows and confused how to setup it.
As reading manual not giving me proper understanding,Where & how to proceed.

Please provide any detailed link or document so that i can complete the setup.

Debasish Nayak

Unless you encounter some problems specific to your installation it is simple as the following:

Now, download the handout above and create a folder in your home directory called m103. Copy the handout to this directory and then navigate to the handout directory m103-vagrant-env in your terminal. Bring up your Vagrant environment by running these commands (this will take a few minutes):

vagrant up --provision

This command brings up your virtual machine, if it’s not already running. It also builds directories in the VM and downloads all the software and validation scripts necessary to complete this course.

vagrant ssh

Which step is causing you problems?

Debasish Nayak,

I’m using Windows 10 Pro 64bits version too.
I agree with you, I’m trying all combinations that is possible to find one that can solve setup troubles for 3 days, and until now nothing.

I lost how many combinations starting from reset following configurations from the begin to the end, where I can stop with another type of error.

Than I agree with you, if the MongoDB University revise the Windows setup instructions will be better for us.

Yes i installed. But now after one shutdown, i am not able to login :slight_smile:
MongoDB shell version v4.0.6
connecting to: mongodb://
2019-03-16T14:38:11.987+0530 E QUERY [js] Error: couldn’t connect to server, connection attempt failed: SocketException: Error connecting to :: caused by :: No connection could be made because the target machine actively refused it. :
exception: connect failed


Are you using windows or vagrant for your work?
If it is vagrant first you need to connect and run mongo commands there
Before connecting please check vagrant status from Windows command prompt.You have to be in your vagrant env dir
If vagrant status is up then vagrant ssh to server then start your mongod and connect using mongo

yes i got it…Now it got connected when i login through vagrant

C:\Users\dell>cd m103

C:\Users\dell\m103>cd m103-vagrant-env

C:\Users\dell\m103\m103-vagrant-env>vagrant ssh
Welcome to Ubuntu 14.04.6 LTS (GNU/Linux 3.13.0-166-generic x86_64)

System information as of Sat Mar 16 09:07:53 UTC 2019

System load: 0.04 Processes: 84
Usage of /: 6.0% of 39.34GB Users logged in: 0
Memory usage: 8% IP address for eth0:
Swap usage: 0% IP address for eth1:

Graph this data and manage this system at:

Get cloud support with Ubuntu Advantage Cloud Guest:

9 packages can be updated.
9 updates are security updates.

New release ‘16.04.6 LTS’ available.
Run ‘do-release-upgrade’ to upgrade to it.

Last login: Sat Mar 16 09:07:56 2019 from
vagrant@m103:~$ mongo
MongoDB shell version v3.6.11
connecting to: mongodb://
Implicit session: session { “id” : UUID(“d99df535-608f-439e-8ba5-30a7b3966fee”) }
MongoDB server version: 3.6.11
Welcome to the MongoDB shell.
For interactive help, type “help”.
For more comprehensive documentation, see
Questions? Try the support group
Server has startup warnings:
2019-03-16T09:08:01.082+0000 I STORAGE [initandlisten]
2019-03-16T09:08:01.083+0000 I STORAGE [initandlisten] ** WARNING: Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
2019-03-16T09:08:01.084+0000 I STORAGE [initandlisten] ** See http://dochub.mongodb.org/core/prodnotes-filesystem
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten]
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten] ** WARNING: Access control is not enabled for the database.
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten] ** Read and write access to data and configuration is unrestricted.
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten]
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten] ** WARNING: This server is bound to localhost.
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten] ** Remote systems will be unable to connect to this server.
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten] ** Start the server with --bind_ip to specify which IP
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten] ** addresses it should serve responses from, or with --bind_ip_all to
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten] ** bind to all interfaces. If this behavior is desired, start the
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten] ** server with --bind_ip to disable this warning.
2019-03-16T09:08:02.089+0000 I CONTROL [initandlisten]
MongoDB Enterprise >
MongoDB Enterprise >
MongoDB Enterprise >
MongoDB Enterprise >
MongoDB Enterprise >

Please check this error:
vagrant@m103:~$ mongod --dbpath /data/db --logpath /data/log/mongod.log --fork --replSet “M103” --keyFile /data/keyfile --bind_ip “,” --sslMode requireSSL --sslCAFile “/etc/ssl/SSLCA.pem” --sslPEMKeyFile “/etc/ssl/ssl.pem”
about to fork child process, waiting until server is ready for connections.
forked process: 12122
ERROR: child process failed, exited with error number 1
To see additional information in this output, start without the “–fork” option.

Please try to run without fork option
When you run without fork it runs in foreground and throws any error to terminal
Also check mongod.log
May be some path is wrong or mongod not able to find the file or not able to write

I am using Windows 10. I installed Virtual Box and Vagrant. Under my home directory c:\users\nikhil , I created m103 directory. I copied m103-vagrant-env.zip to this m103 directory. If I run vagrant status from m103 directory, I get this error :
c:\Users\nIKHIL\m103>vagrant status
A Vagrant environment or target machine is required to run this
command. Run vagrant init to create a new Vagrant environment. Or,
get an ID of a target machine from vagrant global-status to run
this command on. A final option is to change to a directory with a
Vagrantfile and to try again.

Please go to the vagrant-env dir and run your command
It should work

Thanks, that worked, Now getting this error at the end of output from vagrant up.
==> mongod-m103: Successfully added box ‘ubuntu/trusty64’ (v20190312.0.0) for ‘virtualbox’!
==> mongod-m103: Importing base box ‘ubuntu/trusty64’…
==> mongod-m103: Matching MAC address for NAT networking…
==> mongod-m103: Setting the name of the VM: mongod-m103
==> mongod-m103: Clearing any previously set forwarded ports…
Vagrant is currently configured to create VirtualBox synced folders with
the SharedFoldersEnableSymlinksCreate option enabled. If the Vagrant
guest is not trusted, you may want to disable this option. For more
information on this option, please refer to the VirtualBox manual:


This option can be disabled globally with an environment variable:


or on a per folder basis within the Vagrantfile:

config.vm.synced_folder ‘/host/path’, ‘/guest/path’, SharedFoldersEnableSymlinksCreate: false
==> mongod-m103: Vagrant has detected a configuration issue which exposes a
==> mongod-m103: vulnerability with the installed version of VirtualBox. The
==> mongod-m103: current guest is configured to use an E1000 NIC type for a
==> mongod-m103: network adapter which is vulnerable in this version of VirtualBox.
==> mongod-m103: Ensure the guest is trusted to use this configuration or update
==> mongod-m103: the NIC type using one of the methods below:
==> mongod-m103:
==> mongod-m103: https://www.vagrantup.com/docs/virtualbox/configuration.html#default-nic-type
==> mongod-m103: https://www.vagrantup.com/docs/virtualbox/networking.html#virtualbox-nic-type
==> mongod-m103: Clearing any previously set network interfaces…
==> mongod-m103: Preparing network interfaces based on configuration…
mongod-m103: Adapter 1: nat
mongod-m103: Adapter 2: hostonly
==> mongod-m103: Forwarding ports…
mongod-m103: 22 (guest) => 2222 (host) (adapter 1)
==> mongod-m103: Running ‘pre-boot’ VM customizations…
==> mongod-m103: Booting VM…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “04501f08-0f01-4acf-9ab8-27f575e55333”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole

What does vagrant status say?
Try vagrant up --debug
Check our forums
Please check this post: Problem Starting up Vagrant in Windows

My be some security/firewall settings
Virtual box/Vagrant consume lot of resources
Try to reboot and other options suggested in our forums

Looks like solution to this vt-x error is to enable vitualisation at the BIOS level. I am using Windows 10 and I am using the steps to bring up BIOS . BUt the Advanced options under Troubleshoot is not showing UEFI Firmware settings. I have tried thrice so far. None of teh shown options seem to help with what I need.