Unable to terminate sync

Realm sync stopped working, showing the error

Sync has stopped between Atlas and Realm. Fix this issue by attempting to restart sync for Atlas.

However, it did not work. I decided to terminate sync but I could not perform this action.

Error message:
only [uri, clusterId, clusterName, clusterType, clusterSize, clusterUpdated, dbUsername, dbPassword, lastUpdated, wireProtocolEnabled, regionName, groupName, orgName, namespacePreimageConfigs, readPreference, readPreferenceTagSets, sync, sync_query, connect_through_mesh] are allowed config options

Is anyone facing the same issue?

1 Like

Hey Yizhe_Koh,

I am having the same issue, started 30 min ago.

Thanks @Natalia_Jagiello & @Yizhe_Koh for raising up the issue, forwarded it to the concern team.

1 Like

Hi @Natalia_Jagiello , @Yizhe_Koh ,

The issue is still being investigated, but we have a workaround:

  • Access the Linked Data Source page of your app
  • From the Actions button of your data source, choose Edit Data Source Configuration
  • Toggle the MongoDB Connection String switch, Save the configuration, and Deploy, waiting for it to be successful
  • Going back to the Sync page, the Terminate and Enable buttons should now work, and the Deploy button should appear again: the flag that you had activated to force the deploy (wireProtocolEnabled) should be set back to false, so you shouldn’t need to go back to the Data Source to restore it, but double check in case.

Let us know if that helps!

5 Likes

Thank you @Paolo_Manna . The workaround did help.

1 Like

Thank you @Paolo_Manna , this works for me!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.