Unable to start vagrant up

Command: [“startvm”, “d62496b5-b357-4f88-a616-59cb4b525f15”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole

Hi Jacob,

I just resolved the exact same issue. The trouble for me was Hyper V running (used for Docker). I disabled it following Rohit’s solution here: Lab: Setting Up the Vagrant Environment

Hopefully that will get you onto the next step.

i don’t have Hyper V on my computer

I don’t have Hyper V on my computer. Thanks

What is your OS?
Did you try to reboot your system
May be incompatible versions of VB/vagrant

Enable virtualization in the BIOS.
Make sure you have Hyper-V turned off in Windows 10 For Windows 10: Press Windows key. Type “Turn Windows features on or off” Deselect checkbox next to Hyper-V. Select OK. Select Restart now.

my OS is Windows 10. I have Enable the virtualization in the BIOS already but problem still not solved.

my OS don’t have Hyper-V

May be course instructors can help you more on this
Please check if this link helps

Also in some installs hyper-v gets installed by default
Please disable from services or check event logs

1 Like

Hi @Jacob_28713,

Looks like hyper-v is not disabled in your system.

Please take a look at the following threads and see if they can be of any help to you.

Lab: Setting Up the Vagrant Environment M103: Basic Cluster Administration

Microsoft Windows [Version 10.0.18362.356] © 2019 Microsoft Corporation. All rights reserved. C:\Users\Rohit\m103\m103-vagrant-env>vagrant up --provision Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider… ==> mongod-m103: Importing base box ‘ubuntu/trusty64’… ==> mongod-m103: Matching MAC address for NAT networking… ==> mongod-m103: Setting the name of the VM: mongod-m103 ==> mongod-m103: Clearing any previously set forwarded ports… ==> mongod-m103: Clearing any previously set…

M103 vagrant issue M103: Basic Cluster Administration

Hi @satyam_04512, Kindly take a look at the following post for reference: Please get back to me if you still face any issues. Thanks, Muskan Curriculum Support Engineer