Unable to see video database in compass

I have connected successfully as it is shown in lecture video but i found only admin and local databases …No video database.Please help me out as soon as possible

Most likely you connected to local host

Are you trying to connect class cluster or your test cluster?

1 Like

Seems like you are connecting to your Free Atlas sandbox cluster which is right by default it would have only those two mentioned DBS you will need to create a new db called video either from mongo shell or compass

1 Like

I connected to primary node of sandbox cluster through compass as shown in lecture
Connecting to Your Sandbox Cluster from Compass

video database already present in that cluster which is created for course purpose…is it or we need to create it?

In the first post you mentioned not able to see video
Now you mentioned you can see video

Actually there are two clusters
One is classroom and other is sandbox(here you are creating your own DBs,load etc)
Make sure which one you are using.Go as per instructions in lecture
As Yash mentioned above you need to create video in your sandbox

1 Like

And be careful to note that the two databases do NOT contain the same data, nor the same fields.

Thank you all for your replies…i just now got to know that i skipped loading Data into Sandbox video lecture in which i should load Movie Details Data Set into sandbox cluster.

1 Like

I am connecting on a Windows PC with Compass and can only see the admin and local databases. The video database is not showing up and I followed Shannon’s video tutorial. I tried connecting to my .js file but it is not being able to open up. Any help would be appreciated to resolve this issue.

Please follow the same topic where you have posted your query you will get the required answer.

Hi Omar_41205.

Let me know if this is the case and if not, please re-import the data and share the error/screenshot while loading js file. Make sure you are able to access the file and are in the same directory.


These are the screenshots of the errors I get while trying to load the js file.


After connecting to mongo you run the load command as below:

MongoDB Enterprise Cluster0-shard-0:PRIMARY> load(“loadMovieDetailsDataset.js”)

Hi Omar_41205,

You need to run mongod instance from the directory loadMovieDetailsDataset. After connecting to Mongo, as @Ramachandra_37567 said, run load("loadMovieDetailsDataset.js").


I also have the same problem. I can not access “loadMovieDetailsDataset.js”. And when I try run the load command as you mention , it stays still.

It is the screenshot of my cmd. Please kindly check it. Thank you in advance.

Your first query is correct except you need to replace the double quotes in shell:

PRIMARY> load("loadMovieDetailsDataset.js")


Hi…You have to go to the directory where you saved loading file in command prompt and then run that load command…i think then it will work…

1.exit from that shell
2.go to the directory where you saved
3.connect to mongo shell
4.load dataset

I’ve already followed by your step, but it still error. Could you tell me another method please.

I tried it, but nothing changed.