Unable to see "connect via Mongo Shell"

Alright guys (@James_58604 and @Shubha_19623)

Here’s the newer version connection string that’ll connect you to the cluster:
mongo "mongodb+srv://cluster0-jxeqq.mongodb.net/test" -u m001-student -p m001-mongodb-basics

Is this what you were referring to @James_58604?

The 3 part version is still preferred.

I can confirm that this new string worked to the Class Cluster; then I replaced jxeqq with my 5 character ID of my sandbox cluster - - and it worked to my sandbox.

What I was using before, in my work-around, was the old 3 part syntax given in the lecture to the class cluster…and as I noted before with this syntax also if you replace jxeqq with your 5 character ID it will also work.

The class lecture video is dated. thanks 007

Good spot! It looks like Atlas is using that convention for the free tier.

Yes and we’re told that they’re working on some updates.

Hi James_58604
There is no issue with your srv string.I can connect
You got syntax error as you used <> characters for the user

I am getting bad authentication with standard password for your short srv connect string and also long string

@Ramachandra_37567 am trying to figure out my atlas settings, but they all looks fine as per the lecture video

Hi @James_58604,

I’m glad your issue got resolved. Feel free to reach out to us if you have any other query.

Hi @Shubha_19623,

Can you please share the password as well so that I can try to connect from my end ?

Shubham Ranjan
Curriculum Support Engineer

@Shubham_Ranjan passward : m001-mongodb-basics

I already tried using that password much earlier in the discussion and it didn’t work.

So it’s either @Shubha_19623 hasn’t Whitelisted the IP address for his machine/everyone or he’s using the wrong password.

@Shubha_19623 can try (which doesn’t work for me):
mongo “mongodb+srv://cluster0-qz4jl.mongodb.net/test“ --username m001-student --password m001-mongodb-basics

Hi @Shubha_19623,

Can you please make sure of these two things :

  1. You have updated your IP Whitelist configuration to Allow Access From Anywhere.

  2. This credentials is correct :

    Username : m001-student
    Password : m001-mongodb-basics

If you are not sure then please delete this user and create a new one by following the instructions mentioned below.

  1. Click on the “Database Access” tab in the home page of your atlas account.

  2. Delete the existing user m001-student.

  1. Now click on “ADD NEW USER”.

Create a user with the following credentials:

  • username: m001-student
  • password: m001-mongodb-basics

Give this user the privilege to Read and write to any database:

Once done, I think you should be good to go.

Hope it helps!

Shubham Ranjan
Curriculum Support Engineer

oh - okay Rama - did not realize the <> were to indicate replace…am not a command line person and maybe had XML on the brain - - thought they were literal.

so it did work - BUT - the prompt then for the password is an issue - - there is no echo back to the keystrokes… in the end I blindly entered the pw and yes it did work…but will assume lots of people will have trouble with this…

one might consider using italics rather than the <> symbols in your screen to users…

thanks though…

@Ramachandra_37567 I didn’t even notice that. Good catch!

It’s a common security feature to stop prying eyes that’s why the new connection string omits this option. You will also notice from previous posts that I included the --password <password> option within the connection string. In the real world, you probably wouldn’t do this.

And <> is another common syntax used in technical documentation.