Unable to run either tests or index

I have created my cluster, connected to via the shell and loaded test data to the atlas mflix db.
However, when I run npm start i get:
C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js>npm start

server@1.0.0 start C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js
nodemon -L ./index.js
[nodemon] 1.17.5
[nodemon] to restart at any time, enter rs
[nodemon] watching: .
[nodemon] starting node ./index.js
MongoParseError: URI does not have hostname, domain name and tld
at parseSrvConnectionString (C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-
at parseConnectionString (C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js
at connect (C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js\node_modules\m
at connectOp (C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js\node_modules
at C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js\node_modules\mongodb\li
at new Promise ()
at executeOperation (C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js\node_
at MongoClient.connect (C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js\no
at Function.MongoClient.connect (C:\Users\Bob\SWDev\Training\MongoDB-M220\mf
at Object. (C:/Users/Bob/SWDev/Training/MongoDB-M220/mflix-js/src
[nodemon] app crashed - waiting for file changes before starting…
Terminate batch job (Y/N)? y

And when I run C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js>npm test -t db-connection I get:

> server@1.0.0 test C:\Users\Bob\SWDev\Training\MongoDB-M220\mflix-js
> jest --passWithNoTests "db-connection"

Determining test suites to run...Setup Mongo Connection
 FAIL  test/db-connection.test.js
  ? Test suite failed to run

    TypeError: Cannot read property 'close' of undefined

      17 |
      18 |   async teardown() {
    > 19 |     await this.global.mflixClient.close()
         |                                   ^
      20 |     await super.teardown()
      21 |   }
      22 |

      at MongoEnvironment.teardown (test/config/mongoEnvironment.js:19:35)
          at Generator.throw (<anonymous>)

Test Suites: 1 failed, 1 total
Tests:       0 total
Snapshots:   0 total
Time:        5.589s
Ran all test suites matching /db-connection/i.
Teardown Mongo Connection
npm ERR! Test failed.  See above for more details.

Since I haven’t done any coding yet, the problem must be in my setup.
I’m on Windows7,
Here is my .env file:

# Ticket: Connection
# Rename this file to .ini after filling in your MFLIX_DB_URI and your SECRET_KEY
# Do not surround the URI with quotes

Hoping someone can help.

Hey Rob
Nah, it was a fat finger in the connection string in .env
I saw that remark about the .ini That’s not correct. But thanks.
Trying to delete the post.