Unable to install mongo shell in Windows machine

Could someone help me in installing mongo shell

Hi Jyoti

what is the problem?..

In this web page https://www.mongodb.com/download-center/community download installer for windows


Its stuck here since last 2hrs Not sure whether it takes this long to install.

I went trough the same issue, to solve the problem I installed the 3.6.8 version and it did work just fine.

Hope it work for you!


Tried installing 3.6.8 version still facing the same issue. Stuck since 2hrs.

I left installing it all night, next morning was installed, run the exe. mongo and work just fine.

1 Like

Tried installing 3.4.17 version and it got installed within few minutes. Thanks alot for your help :slight_smile:

Mongo DB Server is installed ok but when I try to run mongo either by Double clicking Or By Admin Command Line , message appears stating : api-ms-win-crt-runtime-l1-1-0.dll is missing. I downloaded the dll but cannot be installed by regsvr32

You have also opened a new thread about this question, so there’s no need to necro this thread :slight_smile:

Let’s continue here ->

Took me a long time to find this: https://www.mongodb.com/download-center/enterprise/releases
This is the msi for version 4 install to a windows 64 os.
On the user name profile dialogue, I checked the “run service as a local or domain user” and entered period for account domain BUT entered my local account name on my PC and the password for my local account.
When running Mongo shell, reload your CMD after updating environment variables with the path to the Mongo bin folder.

Thank you!

I went trough the same issue.

I’m trying to install version 3.6.9.

Mind you, that has absolutely nothing to do with the Mongo shell. What you’re stating there is related to MongoD, the database service. You’ve just told Windows to run a MongoD on your computer, which may not have been your intention.