Unable to import data

unable to import data
Failed: error connecting to db server: server returned error on SASL authentication step: bad auth Authentication failed.
connection string used->mongorestore --drop --gzip --uri “mongodb+srv://m220student:@mflix-dt8nn.mongodb.net/test?retryWrites=true&w=majority” data

Looks like your are missing a password.

thanks for the help :slight_smile:

but still facing a different issue
Failed: mongorestore target ‘data’ invalid: FindFirstFile data: The system cannot find the file specified
connection string-mongorestore --drop --gzip --uri “mongodb+srv://m220student:m220password@mflix-dt8nn.mongodb.net/test?retryWrites=true&w=majority” data

You have to run the command where the data directory is located.

1 Like

I ran into an error importing data as well. The error I have is:

2019-06-23T09:26:57.974-0400 error parsing command line options: error parsing uri (mongodb+srv://m220student:m220password@mflix-vbwxu.mongodb.net): lookup mflix-vbwxu.mongodb.net on cannot unmarshal DNS message

The command I ran:
mongorestore --drop --gzip --uri "mongodb+srv://m220student:m220password@mflix-vbwxu.mongodb.net" data

Please check this link

Cannot unmarshal DNS message - Error while importing data to mongo from mflix-js