"Unable to Fetch Movies" error

Hello all!

I just set up the environment and project and tried running the application but I see the error “Unable to Fetch Movies” on the browser.
On the console, I get this error servlet.service() for servlet [dispatcherServlet] in context with path [] threw exception [Request processing failed; nested exception is com.mongodb.MongoQueryException: Query failed with error code 8000 and error message 'user is not allowed to do action [find] on [mflix.movies]' on server mflix-shard-00-00-mqpxj.mongodb.net:27017] with root cause

I found this on Stackoverflow, but didnt solve my problem. There was another student with this problem, tried that solution too, didnt work

Please check this if it helps

Not able to read from mflix.movies

Hi @ameyaraje,

After reading the error message:

the user you are providing in the connection URI is not allowed to execute the find command.

Make sure you are providing the user credentials in your connection string URI.


Hi Norberto,
I hadn’t added the username and password. Adding that solved the issue, but not completely. I see a list but none of the images show up, it says “Images failed to load”. Any suggestions?
The application still runs fine and I was able to complete the first ticket successfully

Hi @ameyaraje,

This might be caused by the imdb image http requests rate limits.
Can you send me a print screen of your browser and the developer console error output ?


A bunch of 503s