Unable to execute run.py


I am unable to run the application.

ERROR: ImportError: DLL load failed. The specified module could not be find.

I used this in dotini_win file before renaming it to .ini :

MFLIX_DB_URI = mongodb+srv://m220student:m220password@mflix-ppdp9.mongodb.net

and then this

MFLIX_DB_URI = mongodb+srv://m220student:m220password@mflix-ppdp9.mongodb.net/test

Both have failed and the same error is coming. The relevant screen shots are attached.

Pls help.


1 Like

Have you used the pip command to install all required dependencies?

1 Like


I did step by step whatever was given in Chapter-2 Driver Setup.

I didn’t find any pip command in it.

Pls guide.




Sorry, I missed it. I just located it in the chapter-2.

pip install -r requirements.txt

But, now I am getting another issue. Last time, I had set up the path, since I had installed Anaconda earlier. Conda command had worked last time.

conda create --name mflix

Now, it says it is unrecognized command. I checked the path in the environment variables. Surprisingly, the path did not have the anaconda path. Now, I have again stored the requisite path m220-path

C:\Users\HP PC.anaconda\navigator;
C:\Users\HP PC.anaconda\navigator\Scripts\

But, still it is saying, conda is not recognized command.

Pls guide.



After a lot of efforts, I could find the mistakae. I had given the path of Anaconda instead of Anaconda3.

But, now the PIP command is giving huge list of errors. screen shot attached.

I don’t know what is happening. Every step is bringing new hurdles. It seems difficult to finish this week’s assignment.

Pls help.



Pls help. Time is running out. Tomorrow is the submission date.


I also got the following error while trying to execute run.py

C:\mflix-python>python run.py
Traceback (most recent call last):
File “run.py”, line 13, in
app.config[‘MFLIX_DB_URI’] = config[‘PROD’][‘MFLIX_DB_URI’]
File “C:\Python372\lib\configparser.py”, line 958, in getitem
raise KeyError(key)
KeyError: ‘PROD’

@Shiv_Pratap_48664, please do not post the same question in 2 different threads.

SSL errors are often caused by Internet-security software installed on your host OS, or by a proxy server on the network.

Are you by any chance working at your company network, or on a company computer?

To sum it up: SSL certificate issues either mean that A) the target website was hacked, or is having technical difficulties, or B) someone is doing a Man In The Middle attack on your traffic. This could be an actual attacker, or a company proxy server (or stuff like McAfee) that is breaking open your TLS/SSL traffic. We cannot help you with that though.

1 Like


I am working on my personal laptop not on a company computer.

I don’t have any antivirus installed on my laptop.

Is there any solution ?

Eagerly awaiting


Oh hang on… it’s saying that “the SSL Module is not available”. No clue what that means for pip, but I’m sure you can Google that. Sorry that I’m not much more helpful than that, taking a practice exam right now.

1 Like


Thanks for response and all the best for your exam.

I have already googled it. Somehow, i have been able to do it. Now, again I am stuck.

The mongo command to check the restored data is not working.

It says host not found. Connect failed.

Now, what to do ?

Isn’t there anyone else available who can help me… I can do it only right now. I cannot access it from my office. By the time I reach home tomorrow, the time will be over and I will not be able to get any certificate for this course.

Urgent help pls.



At last, i reached the last leg. Everything done.

Now, pytest -m connection is giving problem.

I tried : python run.py.

All options are giving errors.

The last one may be of some use: “Principle of Least Privilege: It doesn’t appear you have configured the application user”.

What to do?

Thanks and regards

I’m going to be brutally honest here, but this is a training course with self-study and lab exercises. Right? So the whole point is for you to hack at it, and to keep hacking at it, until it works. If you can’t get the first basic setup to work, it’s may be a good sign that you need to go back to the basics first. The forums are not intended as your go-to every time an error pops up.

Now I will admit: M220P is different from the other trainings like M001, M103, etc. With the M220 courses you’re being forced to work with and debug someone else’s code. I didn’t particularly enjoy that part… But that’s the deal with this one: configure the webapp to work and then start tweaking the code.

1 Like

Thanks for this thankless reply. I have seen your non-cooperative attitude. What are TAs for - if you can’t solve an error.

Anyway, Thanks.

@Vineet_77325, Ms. @Tess_Sluijter is not a TA she is a person like you and I taking the courses and she is kind enough to help others and she is really good at it.

1 Like


I sincerely apologize. But, her comments were also uncalled for. I had already been doing what she told me to do - googling. I was in a hurry to sort out the problem because of the limited time at my disposal.

If she is not a TA, then it is all the more unfortunate for me that no TA could come to my rescue.

Anyhow, nothing can be done now. Time is gone. I am leaving this course here itself. It is of no use banging my head without any help from other side. :cry:

Again, sincerely apologize, if I have hurt anyone.

Thanks and regards

she is kind enough to help others and she is really good at it.


Awww shucks Steeve :slight_smile:

@Vineet_77325, nobody was hurt, not in the least myself. The thing is: none of the issues you ran into were insurmountable and they were part of the learning process. If you’re going to be doing Python development, MongoU assumes that you can get a 'Conda and PIP environment working pretty quickly and troubleshoot it if needed. I had trouble with it myself when I took the class, because I’ve only done the most basic of Python stuff and never touched a “real” IDE or Python env before.

So let’s turn this the other way around: I apologize for being outright blunt.

Extremely Sorry. After posting I thought that I have not posted in appropriate thread. Hence Reposted. Will not repeat the mistake. Sorry for inconvenience

1 Like