Unable to connect to my sandbox

All of a sudden i cannot connect to my sandbox cluster anymore. i didnt change anything but now i get a bad auth Authentication failed message or invalid schema, expected ‘mongodb’ or ‘mongodb+srv’. ive tried various connection strings to try and get back to my cluster but it wont work.

Post a screenshot of what you are trying that shows the error you are getting.

The connection string is the thing inside the quotes that starts with mongodb and ends with test. This is not how you specify the user name and password. Go back to your Atlas cluster click connect and choose Compass as connection method.

1 Like

i tried that and other variations but id doesnt bring anything up. it just brings me to a white screen.

It looks like you have not whitelisted your IP address.

i set that up when i initially created my cluster. i followed the steps to whitelist my IP address (
I also didnt have this issue before and i havnt changed any settings.

You are right. I was able to connect with mongo shell so the the IP whitelist is definitively correct.

I am starting to think it is an issue with Compass. I get the same error with all my clusters.

Which version do you have?

Mine is 1.20.4

I downloaded 1.22.1 (the latest from the web site) and it worked. However, the install required a reboot because it looks like some compass gui thread were still alive despite the fact that all my compass windows were closed.

I will try to simply reboot. May be there is some issues that make Compass in a funny state. That’s under Windows after all. I will check tonight on my linux laptop.


I have 1.17.0 installed in Linux and I have no problem accessing any clusters.

I really suspect some Windows issues happening. Try rebooting before anything else.

Linux rocks, Windows s.cks :sunglasses: