Unable to connect to Mongodb Cluster after moving the primary to new node

We have setup a MongoDB Atlas cluster in Single Region (us-east-1) with a private link on us-east-1 and us-west-2. After that we have implemented the following steps.

  1. Moved one node to us-west-2.
  2. Tested connectivity for the nodes after the move. It works well.
  3. We tried moving the primary from us-east-1 to us-east-2.
  4. When we tried the connectivity after re-configuration, we are unable to connect to the cluster.
    Is this a correct process ? If so, why am I losing the connectivity?
1 Like

Do you have peering between your app tier regional VPCs/VNets (not sure if this is AWS or Azure) so as to be able to reach both regional privatelink enabled nodes from one or the other side?

1 Like

This is in AWS. We do have private link setup on east and west region. When we just move a node from a single region to a multi region, connectivity is working.
Initially, one node in us-east-1 is primary. We are trying to re-configure to make the node in us-east-2 to primary by assigning a higher priority, the setup works. However the connectivity using private link fails.