Unable to connect to mongo cluster from compass

Hi i am unable to connect to mongo cluster from compass

Hey @proma

There is a similar post to this happening here. Does your config look like the screenshot from the other post?

yes it does look exactly the same

This is interesting as I am able to connect with that config as we speak. Perhaps there is a different issue going on since I have seen a few people have an issue connection to Compass.

Hi @proma,

Can you please share the screenshot of the configuration parameter that you are passing to the compass and also share the error message that you are getting while trying to connect to the cluster.

Note : Please ensure the following:

  1. There are no blank spaces present in any of the parameters that you are passing.
  2. Please confirm that port 27017 is not blocked by clicking http://portquiz.net:27017.
  3. You are able to ping cluster0-shard-00-00-jxeqq.mongodb.net

Shubham Ranjan
Curriculum Support Engineer

[http://portquiz.net:27017.] i am unable to access the link here

Is there any way i can know whats causing this issue

Hi @proma,

Hi please do the following and share the screenshots. Start your terminal or Command Line and execute this command

ping cluster0-shard-00-00-jxeqq.mongodb.net

Also the error in your screenshot is not visible. Kindly scroll to the top after hitting the connect button to see the error message and share the same with us.

Additionally you can refer this great post About the Chapter 1: Compass Connection by @Kanika and make sure you are doing everything right.

1 Like

Hi @Shubham_13709 I cannot see any error while i am connecting in the compass tool…it just gives a timeout.

i hv pinged the url and its success

Hi @proma,

Can you please try connecting to the MongoDB cluster using the mongo shell by executing this command in your command line :

mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/test?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

This way we would be able to figure out if there is any network problem or it is a compass specific issue. And also kindly make sure you have downloaded the correct version of the compass 1.18.0 (Stable) as shown in the screenshot below.

I had the same problem with connection. Ping worked, telnet to 27017 worked, connection via shell worked too, but in the Compas window I had the error:

Resolved by changing the SSL field from System CA / Atlas Deployment to Unvalidated.