Unable to connect to Campass

Good day, I’m able to connect to Compass, even though all the details on the connection seem fine.
I’m using windows 10, and running on Compass version 1.19.12.

I have ensured I can successfully ping the host name.
See image attached

The most probable cause is that you did not whitelist your IP address.

Hi Steve, thanks for the quick promptness. Now how do I go about doing that?

You log to your Atlas account, select your cluster and in the security setting there is an option to whitelist address. I do not have access from here so I cannot provide you with screenshots.

hi Steve, thanks for the feedback, I believe this is where I need to be, but I still fail to connect.

Yes, that’s the right place.

Now, verify the URI, and preferably select the SRV style URI.

You also might have a firewall issue.

You may use the tool mentionned in https://www.mongodb.com/community/forums/search?q=portquiz to see if your firewall is an issue.

Hi Steve, I have done the test as well as the ping. Check it out.

Hi @Dercio_18652,

As I can see in the first screenshot, you are having trouble connecting to the Atlas class cluster. The ECONNREFUSED error means that there is a networking issue. I’m aware that the ping was successful and the ports are not blocked.

I will still recommend you to try to connect from some other network such as your home network.

Please get back to us if the issue still persists.

Shubham Ranjan
Curriculum Support Engineer

thanks @Shubham_Ranjan, will give it a try when I arrive home.

thanks a Million @Shubham_Ranjan, it worked like a magic. I connected with my hot spot and im now connect to campass.

@steevej-1495, thanks a million as well for assisting me as well, and not giving up.