Unable to connect to atlas cluster at Chapter 0


I’m trying to connect to the M121 Atlas cluster, and I’m getting a funny error. I’ve looked through the MongoDB docs for making connections to clusters and copied the same code but I keep ending up with the same error result.

mongo command:
mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

and error message:
2019-08-24T23:20:52.656-0300 E QUERY [js] uncaught exception: SyntaxError: unexpected token: string literal :

Please assist

Don’t see any issue with your command
I am able to connect
May be while cut & paste some invalid character came or some quotes missed?

I tried that also as well. Even typing manually but still giving the same error

It was me :man_facepalming:. I was running the command inside the mongo shell

1 Like