Unable to connect Sandbox cluster using command prompt

I am unable to connect to Sandbox cluster from command prompt. Could you please assist here.


Most likely wrong user name or password.

@steevej-1495 I have used the correct credentials as mentioned below :

mongo “mongodb+srv://sandbox-seaje.mongodb.net/test” --username m001-student -password m001-mongodb-basics

I can connect to your cluster.onnect string looks fine
Please make sure no spaces or invalid characters
quotes could be the problem
Use double quotes (not inverted commas)

I am still unable to connect to my cluster, i am using the below

mongo “mongodb+srv://sandbox-seaje.mongodb.net/test” --username m001-student --password m001-mongodb-basics

but i am able to connect to another cluster which mentioned below:

mongo “mongodb+srv://cluster0-jxeqq.mongodb.net/test” --username m001-student --password m001-mongodb-basics

I too can connect.

In one screenshot, show us a failed connection to your Sandbox cluster and a successful connection to the Class cluster.

Not sure , what mistake i am doing.

I am getting the below error, when i use below command:

mongo “mongodb+srv://sandbox-seaje.mongodb.net/test” --username m001-student --password m001-mongodb-basics

… and this screenshot please?

Please find the below screenshot of successful connection to another cluster

That’s peculiar! I can’t see anything wrong and all your nodes are healthy. Can you share a screenshot the Network Access page on Atlas?

And try these three:

  1. mongo "mongodb+srv://sandbox-seaje.mongodb.net/test?authSource=admin&replSet=Cluster0-shard-0&tls=true" --username m001-student --password m001-mongodb-basics

  2. mongo "mongodb+srv://m001-student:m001-mongodb-basics@sandbox-seaje.mongodb.net/test?authSource=admin&replSet=Cluster0-shard-0&tls=true"

  3. mongo "mongodb://sandbox-shard-00-00-seaje.mongodb.net:27017,sandbox-shard-00-01-seaje.mongodb.net:27017,sandbox-shard-00-02-seaje.mongodb.net:27017/test?authSource=admin&replSet=Sandbox-shard-0&tls=true" --username m001-student -password m001-mongodb-basics

@007_jb I have tried with all the three but still it didn’t worked.

Please find the below network access screenshot for the reference.

Is anything wrong with region chosen?? Attaching screenshot with region also for your reference. Currently i am in France.


That was going to be my next question but I’m in the UK and I can connect. Very strange!

Do you get the exact same error message from all three commands?

Error 1:

Error 2:

Error 3:

This JIRA ticket is similar to yours.


  1. Using Compass to connect
  2. A fresh install of MongoDB (which comes bundled with the mongo shell) or try a different mongo shell version.
  3. A different region, perhaps the same region as the Class cluster (AWS - US_EAST_1).

Hi @Chaitanya_Gattu,

If your issue is still not resolved, then please reach out to the atlas chat support team here : http://cloud.mongodb.com/

~ Shubham

Hi there, I’ve figured out what is happening. The poblem is the IDE on the https://university.mongodb.com/mercury/ > Lab: Connect to your Atlas cluster. it is broken. I mean that IDE doesn’t work properly. Once you try your code for the first time it never trully reset the workspace anymore, and keep trying the same code again and agian. I have tried the instruction “mongo-version” (after push the reset workspace button), but I get the same response as usual [FAIL] “Successfully connected to the Atlas Cluster”… etc etc. It doesn’t make sense at all. If I passa the instruction mongo-version the answer, “befor run Test”, can’t be - [FAIL] "Successfully connected to the Atlas Cluster.

Most likely you did not enter the command in the correct area.

Post a screenshot of the whole IDE that shows how you are connecting.