Unable to connect Mongo shell

All the commands worked till connecting the path.
When I typed Mongo on the Command prompt it shows connection failed.
I have downloaded Community edition as it only supported SSL where as the enterprise edition did not support SSL.
Will it be because of the Community edition?
Here is the message I get :

You need to run mongod before connecting to mongo shell.

$ mongod

Then, open a new tab/terminal. And run:

$ mongo


Thank you. It worked a while ago. And now when I tried $ mongo it is showing connection failed.

When it was connected I tried building a Cluster.
I copied the list of clusters and the replicate set details from Atlas and tried connecting to Mongo shell.
It shows PRIMARY but it says
“Error while trying to show server startup warnings: user is not allowed to do action [getLog] on [admin.]”
MongoDB Enterprise Sandbox-shard-0:PRIMARY>
Should I proceed further or resolve it?

Yes, you can proceed further. Only you can not perform the action [getLog] on [admin], but we do not use it in the course.

@admnll is right!

The Error is just showing you that user is not allowed to do [getLog] on admin.

But you can continue using Mongo Shell.

MongoDB Enterprise Sandbox-shard-0:PRIMARY>

The above line means you are in the Mongo Shell and you can execute Mongo queries.