Unable to connect compass using the mongo shell

I tried using the method of quit and running the comand outside the mongo shell but getting below error.


1 Like

Is mongodb installed?

If yes it coud be path issue.Have you updated mongdb/bin to your PATH?
Check echo $PATH

Hi @Akhil_Khanna_Khanna,

This :point_down:

~ Shubham

yes, mongodb is installed.

getting below error.

you need to do that outside the mongo shell.

at first i tried doing outside the mongo shell. i have pasted the screenshot above

yes, but you must have fixed the path issue because you are inside the mongo shell. when someone offer a solution follow it. with the path fixed you should try the original command rather than going into another direction.

1 Like

Hi @Akhil_Khanna_Khanna,

I hope you found @steevej-1495’s response helpful.

Please let us know if you are still facing any issues.

~ Shubham

Hi @Shubham_Ranjan / @steevej-1495

Thanks for the help. Issue is resolved now.
PATH was not set in the environment variables.

Akhil Khanna

@Ramachandra_37567 Thanks for the help, it was the path issue.