Trouble with instalation and testing of mflix

Hi iv been trying to install mflix bur have been running into multiple problems (some fixed and one not) In the beginning I had problems with the requierment download not wanting to download a file called pyzmq as it said

“ERROR: pyzmq has an invalid wheel, multiple .dist-info directories found: libsodium-1.0.17.dist-info, pyzmq-18.1.0.dist-info”

this was fixed by downgrading my anaconda to python 3.7.
becous of the previous problem and lab test did not want to work but works now.

The problem Im currently experiencing is that when I go to the localhost website all I get is an failed to connect error. I tried to run “” multiple times and the rest of the connect/test code but to no avail. When I try to run the “” script it comes up with that 0 items were collected and no test were run. I am unsure this error could be because of the previous errors or if this is yet another error.

It is best to post a screenshot of what you are doing so that we see the whole context.

Also post your .ini file. If you cannot connect it is most likely a configuration issue.

So as it turns out I just needed to restart my computer for it to suddenly work. Thanks for the help ether way

That’s great to hear @Fredrik_Forsell and sometimes a fresh terminal window with everything re-loaded or indeed a reboot is indeed the quickest way to sanity check these things! Enjoy the rest of the course and let us know if you have any further questions or issues.

Kindest regards,