Triggers not working when there are more of 4

Hi, I have a M10 cluster with some collections, one of them is called test, so, I have some triggers to some collections, I have 4 and they are working good, but if I add a five one, this doesn’t work, I checked and it’s enabled, this is linked to my test cluster to my test collection, and the collection, cluster and database names are correct, in the code I just have a console.log and the trigger is saved, but when I insert a row in test collection the trigger is not activated, it doesn’t appear in the trigger logs, I test with the other triggers and all are working, just the five one isn’t, I tried to delete it and create it again, but it is not working yet.
Does someone know why?

Hi @Sistemas_Informatico,

The only limitations with triggers in an application is :

MongoDB Realm limits the execution of Trigger Functions to a rate of 1000 executions per second across all Triggers in an application. If additional Triggers fire beyond this threshold, MongoDB Realm adds their associated Function calls to a queue and executes the Function calls once capacity becomes available.

Database Triggers with event ordering enabled are an exception to this rule. Each ordered Trigger processes events in order, waiting for the previous event execution to complete before handling the next event. Therefore, only one execution of a particular ordered Trigger executes at any given time

Can you share the link to your application?

Best regards

1 Like

Hi @Sistemas_Informatico,

As we found on Realm support the command which was used to update the document via Data Explorer was “replace” but the 5th trigger was not configured to be fired on those.

Mystery solved :slight_smile:

Best regards,

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.