Ticket: Create/Update Comments

Hi

The Tests for AddCommentAsync / UpdateCommentAsync fail, however I can get the validation code from the application :D.
Screenshot with fail test error:


Screenshot with my code:

What!! :scream: We will check this out and fix it. Thanks for catching this and sharing with us.

Kanika

When testing TestAddsComment()
in CommentController line: 38 returns null.
var user = await UserController.GetUserFromTokenAsync(_userRepository, Request);
The test fails because of that null user.
Is this a bug or a problem that I have to solve somehow?

Having the same error yet

Still having the same error

It is not the answer on your question. I can’t find the button Add new comment without replying to anybody. So, IsUpser must be true in the UpdateCommentAsync, mustn’t it? I attach the link to the page where the code should be editted. https://university.mongodb.com/mercury/M220N/2021_July_6/chapter/Chapter_3_User-Facing_Backend/lesson/5e8796e3e0b0e5d56e0559ed/answer

404 Not Found. :grinning: What’s the right answer?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.