This lab is worded so confusing

I tried to do anything in this lab and all i get is errors, I cant start mongod and then I try to get the shell going and try to create a user and its says another error. the worst part of all is that I cant get help right now I have to wait to hear from someone by then I have lost time waiting for an answer. I do not know how to do the lab creating first user.

the worst part of all is that I cant get help right now I have to wait to hear from someone

I assume that you have not asked your questions here because I get a banner that says

This is the first time paul_rosero has posted — let’s welcome them to our community!

Please post a screenshot of what you tried that shows the error you are getting.

i moved on because it took 26 mins to get a response from you and I dont have all day to wait for a response. this is the worst way to do things. instead of having people help right there and there instead of waiting. I thought MongoDb was all about speed? it seems like its not.

this is what I mean, I started this chat about an hour ago and I still havent gotten a response in a timely manner

Im doing everything as the last lecture and I’m not getting it right, WHAT AM I DOING WRONG??

I do that on my free time for no salary. Sorry if I am not up to your expectations.


You entered the createUser command at the wrong place. You have to be connected to a server to be able to create a user on that server. That not how they show to create a user.

i get this message when I try to run that command. I am not sure why?

Although the first sentence of the lab is worded

Connect to a mongod instance that has already been started in the background on port 27000 .

you are trying to start another mongod instance using the same configuration file as the one that is already started. There is a difference between mongod, the server and mongo the shell you use to connect and interact with the server.

I was able to get to the part where I switched to admin, and then did db.create like i did before and got an error.

Depending of where you cut-n-paste the command, the double quotes copied are wrong.

Replace all double quotes in your command with double quotes that you type yourself on your keyboard. That is no mongo’s fault. It is html fault with the introduction of the new fancy quotes.