The program 'mongod' is currently not installed

I succesfully installed everything but when I try running the mongod command:

vargrant@m103:~$ mongod

It tells me: The program ‘mongod’ is currently not installed. To run ‘mongod’ please ask your administrator to install the package ‘mongodb-server’

What do I need to do to resolve this?

I tried sudo apt-get install -y mongodb-enterprise --force-yes
but it tells me E: Unable to locate package mongodb-enterprise


Furthermore, for the lab of chapter 0, when I run the validate_box command it tells me:

validate_box: command not found

Running: download_validators results in the same error, i.e. the command is not found.

Btw. when I call vagrant provision I get the following error:

mongod-m103: gpg:
mongod-m103: requesting key A15703C6 from hkp server
mongod-m103: gpg: keyserver timed out
mongod-m103: gpg: keyserver receive failed: keyserver error

The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Hi @Samir_31865,

Please check if you have firewall/anti-virus ensabled on your system.
This can be a probable cause for this issue.

If yes, kindly disable it and try running your process again, let me know if you still face any issues.

Curriculum Support Engineer

Thanks, this is handled by our company’s network administrator and I doubt he will allow to turn off the firewall for security reasons. What exactly needs to be disabled connection-wise to make it work?

Hi @Samir_31865,

Please try and use another network/system for this course in this case if your company’s administrator does not allow you to turn it off.

Curriculum Support Engineer

@Muskan_47318 I have the same problem.
I have an Ubuntu 18.04 installed on my laptop. I installed VirtualBox and Vagrant from their official .deb packages and I have no firewalls configured on my laptop.
At this point, the mongod-m103 box is installed and running in VirtualBox and I can connect to it via vagrant ssh, but there are no scripts there and mongod is missing.

Hi @hami_bahadori,

Can you please check if at line 57 in your provision-mongod file you see the exact same values as below?

sudo apt-key adv --keyserver hkp:// --recv 2930ADAE8CAF5059EE73BB4B58712A2291FA4AD5

To download the validation scripts, please run below command from vagrant box:


If the above doesn’t resolve the issue, please try re-provisioning your vagrant again as below:

Exit your vagrant
vagrant halt
vagrant up
vagrant provision

Hope this helps!


Thanks for replying so fast! :smiley:

Here’s my 57th line:
sudo apt-key adv --keyserver --recv 0C49F3730359A14518585931BC711F9BA15703C6

I don’t have download_validators on my vagrant box. It says “command not found”.

Thanks again for your reply. I’ll try again and let you know what happens.

Hi @hami_bahadori,

Please replace this line with the following one:

Also, try re-provisioning your vagrant if changing the above line doesn’t help, that should work.

Please let me know if it doesn’t and we’ll look into it further.


1 Like

I fixed it! :tada:

This is what I did:

  1. I replaced the 57th line in provision-mongod file
  2. vagrant halt
  3. vagrant destroy
  4. vagrant up --provision

@Muskan_47318 Thanks a lot! :smiley:


Great job @hami_bahadori !

Please feel free to reach out in case of any further issues. :slight_smile:

1 Like