Syntax Error at first try of run.py

Hi,

Starting the course. Was able to install all the environment successfully once I used python3 and pip3 to install all the files in requirements.txt.

When I run “run.py” I get the following syntax error which also appear when I run the pytest.
I have not modified anything at all.

Thanks in advance for the help.

Nevermind, new day, fresher mind.

The error happens when using python vs python3.

My system is 2.7, but I use pyenv and the global is 3.7.5 and the local ( in my environment) is 3.9.5.

I guess when using “python” it uses the system version ???

Just another comment.

The app works and I got the ticket validation.
So all is fine?

For some reason the test doesn’t work. It still give the ‘syntax error’ from above.
This is using “pytest -m connection”.

When I use “pytest-3 -m connection” it gives me another error: flask module does not exist.

I had to revert to python 3.8.8 …in my case I had to actually recompile it since they no longer had the binaries.
from what I know and unless there’s been major updates to the course materials…(doesn’t look like it) 3.8.8 is the Python you want. If you search my posts there’s also a requirements.txt that I updated which had me working just fine on all scores in a venv. both on Windows and Manjaro. Anaconda never worked for me.