Stuck on lab. Change the Default DB Path

In the lab Change the Default DB Path, I am getting errors, can not create the new user required, and thus cannot complete the lab…

Steps taken in the lab so far…

#1. mkdir -p /var/mongodb/db
#2. Entry into mongod.conf
dbPath: /var/mongodb/db
bindIp: localhost
port: 27000
authorization: enabled

#3. Create new user command.
mongo admin --host localhost:27000 --eval ’
user: “m103-admin”,
pwd: “m103-pass”,
roles: [
{role: “root”, db: “admin”}

#4. Error output.
MongoDB shell version v4.0.5
connecting to: mongodb://localhost:27000/admin?gssapiServiceName=mongodb
2020-10-02T19:12:15.299+0000 E QUERY [js] Error: couldn’t connect to server localhost:27000, connection attempt failed: SocketException: Error connecting to localhost:27000 ( :: caused by :: Connection refused :
exception: connect failed

What did I miss? I tried to Reset Workspace to see if I might have caused the problem myself, no change…

Most likely you did not start mongod.

Please post screenshot of all the steps.

Hopefully this works.

Not sure how to link to Google pics here… Since they don’t allow uploading screenshots directly like most forums I am involved in…

I saw only one image and it is when you start mongo. But you cannot connect because

I recommend to view all lessons from the beginning. It looks like you are missing the fundamental difference between mongod, the server and mongo, the client.

Solved, I sort of forgot to add the parameters to mongod startup for the config file… That should have still been fresh in my head…