Starting 4.4 on windows

I can’t seem to get 4.4 to start on windows 10 pro. when i run mongod.exe it simply returns with no output. i get the same result no matter what flags I pass in. It simply won’t start or give any sort of feedback. This is the same with 4.4.0 and 4.4.1. Any ideas on what’s wrong?

Hi @Justin_Lee,

How did you install it? As a service or just the binaries? Which command line are you using to start it?

Usually, for a “Hello World”, mongod just needs a path for the storage:

mongod --dbpath <somePathToAnExistingEmptyFolder>

If you are planning something more serious, I would at least recommend an additionnal --auth, log management, etc.


i’m extracting the zip files and running them as parts of a test framework. I pass more options (via config file) in the “live” version but it fails to start. Running from the command line with no options has, traditionally, returned an error/usage message but I get nothing with 4.4.

This test framework works with the linux downloads. it’s just the windows 4.4.x versions that have never started up for me. But everything back through 3.6 works just fine.

so apparently powershell will just swallow errors but using cmd i get a pop up complaining about a missing vcruntime140_1.dll. so a clue at least if not quite a fix just yet.

Reinstalling the Visual c++ runtime fixed it.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.