Shell and Server Versions Do Not Match

I tried to connect to the cluster via mongo shell, using the following command (as per instructions provided, changed test to city.)

mongo “mongodb://,,” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

But Following image will show the error I am getting.

Please help me.


This is perfectly fine. It’s a warning, not an error.

This will work perfectly okay for M001.

Now I am literally getting no Output here :stuck_out_tongue:

That obviously means that the “Video” database does not exist in the context of your current shell. I’m trying to figure out what you’ve done wrong. Your screenshot is pretty hard to read, because your actions are all-over and there’s plenty of errors to around.

Hint: could it be that MongoDB is case-sensitive? :wink:

Yeah I figured that out. Its because MongoDB is case sensitive. Use the right name with right ‘case’ and it will work just fine.
But then again, why show “Switched to db Anything” if it just dont exist? It would be better to just respond with “No db Found”.

Also, can you suggest a way to bette my cmd fonts? I want to know if there is a Layout design that matches my cmd to your shell.

Thanks again for the help :slight_smile:

Because that’s how MongoDB works :slight_smile: It will implicitly create new databases and collections whenever you want. No need to define schema and other tricky things up front, just “use” them and move on. This is actually something that will be covered in M001.

Also, can you suggest a way to bette my cmd fonts? I want to know if there is a Layout design that matches my cmd to your shell.

Well, there’s always the Powershell shell, instead of cmd.exe :wink: My screenshot shows the Terminal app from MacOS, so that’s a different beast entirely.

Let me see what I can come up with :slight_smile:

Well, that was fast. You could’ve done it too! :slight_smile: Just Google for “cmd.exe change font” and you’ll find plenty of examples, including this one:

1 Like

Thanks a lot :slight_smile:

I am having error connecting via the shell 24%20AM

and also why am I getting “MacOS 64 -bit, without SSL support x64” is that the reason for the error?

Oh come on, you’re not even trying! :smiley: The error about the semicolon has been mentioned no less than five times just these past two weeks!

The reason for your error is because you’re trying to start a mongo shell, from within a Mongo shell.

And so on…

No, check this out.

I tried to exit from the mongo shell and getting the error. 40%20AM

Your screenshot looks like it’s missing a lot; I have no idea what you’re trying to show.

Anyway, you are now back at the MacOS shell prompt. This is where you enter the mongo-shell connection command.

Yes, I did but still showing error

And what is the error now? This is where a full screenshot, or a copy/paste would be helpful.


I am a newbie, I am sorry for the disturbance

Although, it is just a warning. I hope the version difference wouldn’t hinder the performance

1 Like

Exactly :slight_smile: You are no connected, there is no error. The warning is not a problem at all.

1 Like

Hey i am trying to connect my shell with atlas so i can learn the insertOne but i have a server and shell mismatch wich i am thinking is causing the login fail. I cant find a solution can someone help me?

Server and client version mismatches are NOT a blocking issue. They definitely do not block your login.

You have entered the wrong username; “m001-Ruben” is not a valid account on the shared student cluster.

aight thnx for the noticing me on that

1 Like