Setting up mflix - Unable to run app

I am getting this error when running the app.

I have fixed all my dependencies and tried adding the below to no avail.

    <dependency>
        <groupId>org.apache.santuario</groupId>
        <artifactId>xmlsec</artifactId>
        <version>1.4.3</version>
        <exclusions>
            <exclusion>
                <groupId>javax.servlet</groupId>
                <artifactId>servlet-api</artifactId>
            </exclusion>
        </exclusions>
    </dependency>

    <!-- servlet-api 3.1 version has getVirtualServerName() -->
    <dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>javax.servlet-api</artifactId>
        <version>3.1.0</version>
    </dependency>

Hi :wave: @Irah_Rosete,

Welcome to the MDB Community forums :sparkles:

I suspect the problem has 2 primary causes:

  • Your servlet version is older than 3.1.
  • Some other jar has the servlet with a version older than 3.1.

Fix the versions and see if this problem gets resolved or not.

Apart, you could try removing the ./idea and project.iml files and reloading the project.

Thanks,
Kushagra