Service 'MongoDB Server' (MongoDB) could not be installed on Windows 10

I am trying to install MongoDB Enterprise Server on Windows 10 but I get the following error:

Service ‘MongoDB Server’ (MongoDB) could not be installed. Verify that you have sufficient privileges to install system devices.

Has anybody faced the same problem?
Do you know how to overcome it?
Please help me.

Thank you very much.

Hey @Stratos_51626 share the link where you downloaded the file. And is this your personal or work laptop?

Hi @007_jb,
I downloaded it from this link:
The file which I downloaded is called: mongodb-win32-x86_64-enterprise-windows-64-4.2.0-signed.msi

This is my personal laptop at home running Windows 10 64-bit.
Thank you

Try and run it as the administrator. Right-click on the exe file and select Run as Administrator.

1 Like

I have run it as administrator but I still get the same error!
I even run it from command prompt (cmd) as administrator with no success!

Has anybody managed to install MongoDB Enterprise Server version 4.2.0 on Windows 10?
Thank you.

Please download msi again and try to install
or there may be some dependencies missing
Are you installing in default dir or in a different directory?
Sometimes this too can cause issues

Finally I managed to install MongoDB Enterprise Server version 4.2.0 on Windows 10.

Because I am using Windows 10 Home edition, the user that I login into Windows did not have all the administrator rights needed for installing MongoDB Enterprise Server version 4.2.0.

Therefore I had to enable the Built-in Administrator Account on Windows 10. This is a super administrator account that gives you some extra privileges over the normal administrator account.

I followed the steps of Method 3 from this guide: and the problem is solved! :slight_smile:

Good job! :+1:

I didn’t know about this default setting in the Home Edition! I have Pro and didn’t encounter this problem during installation.

Thank you for your help anyway. :slight_smile:

1 Like

Hi @Stratos_51626,

I’m glad your issue got resolved and also thanks for sharing your findings with the community. If you have any other query please feel free to get back to us.

Happy Learning :slight_smile:

Shubham Ranjan
Curriculum Support Engineer