Schema version exeption on App init

We’re having a strange exception on App(id:) without having yet created user or realm the App constructor itself fails with a schema related exception. Here are the logs

NativeiOSApp[5344:350256] Uncaught exception: RLMException: Provided schema version 5 is less than last set version 6.
    0   CoreFoundation                      0x0000000196cd4d8c D2716F2F-688B-3D51-BA8B-17E6553B209E + 630156
    1   libobjc.A.dylib                     0x00000001af939734 objc_exception_throw + 60
    2   NativeiOSApp                        0x0000000100641fb8 _ZL17RLMTranslateErrorIZ49-[RLMApp initWithId:configuration:rootDirectory:]E3$_2EDaOT_ + 128
    3   NativeiOSApp                        0x0000000100641de0 -[RLMApp initWithId:configuration:rootDirectory:] + 436
    4   NativeiOSApp                        0x00000001006422ec +[RLMApp appWithId:configuration:rootDirectory:] + 296
    5   NativeiOSApp                        0x0000000100642448 +[RLMApp appWithId:configuration:] + 96
    6   NativeiOSApp                        0x0000000100642508 +[RLMApp appWithId:] + 72

We’re struggling to shake it off, the posts I find concern later configuration. I don’t see where it can know about schema versions at this point, trying to dig into the init without any success. We’ve tried deleting the app, installing with another bundle identifier, cleaning everything, and we still get the error. Could you give us some pointers as to where it knows about Schema versions 5 and 6 and the resulting incompatibility?

As soon as the app touches Realm in any way, the schema is created and a migration block may be in play.

Is this a local or sync’d Realm?

If local, do you have a migration block? At what point does your app first touch Realm? Touching meaning anything like let realm = try! Realm()

Perhaps including some code - your AppDelegate startup code, if it incldudes any Realm references would help.