Rsync is not recognized

even though i have set up path variable for my winGW it’s not recognising the rsync .although it recoznize the ssh command what to do?

i fixed it .its working now

It’s not working for me any clue please?

its a typo in my case .please make sure you name all correctly.
if again its not working paste your code here

Hi Prashant.

Rsync is not working for me also.

R1 R2 R3

Path : %USERPROFILE%\AppData\Local\Microsoft\WindowsApps;C:\MinGW\msys\1.0\bin;

Hi @Sophia_78936,

Kindly take a look at the following thread for reference to resolve the issue.

Hope it helps!

Curriculum Support Engineer

I uninstalled and resinstalled rsync alone and tried again same error.Restared also.
When tried from bin in the command prompt I am getting the below error.

Use “rsync --daemon --help” to see the daemon-mode command-line options.
Please see the rsync(1) and rsyncd.conf(5) man pages for full documentation.
See for updates, bug reports, and answers
rsync error: syntax or usage error (code 1) at /usr/src/rsync/rsync-3.0.8/main.c(1420) [client=3.0.8]

Hi @Sophia_78936,

Can you please try following the steps mentioned in the course handouts for lecture Setting up Vagrant ?

Please get back to me if it still doesn’t work for you.

Curriculum Support Engineer

Hi @Sophia_78936,

I think you have installed rsync successfully.

This message is mostly displayed at the end when you run rsync on command prompt.

To verify the installation of rsync, you can also run the following command in Command Prompt:

rsync --version

You should get output as shown in the screenshot below:

Please let me know, if you have any questions.


Hi Sonali,

Yes I am getting the mentioned output when i run rsync --version from the path.

C:\MinGW\msys\1.0\bin>rsync --version
rsync version 3.0.8 protocol version 30
Copyright © 1996-2011 by Andrew Tridgell, Wayne Davison, and others.
Web site:
32-bit files, 32-bit inums, 32-bit timestamps, 64-bit long ints,
socketpairs, hardlinks, symlinks, no IPv6, batchfiles, inplace,
append, ACLs, no xattrs, iconv, no symtimes

rsync comes with ABSOLUTELY NO WARRANTY. This is free software, and you
are welcome to redistribute it under certain conditions. See the GNU
General Public Licence for details.

But When I tried directly from my user instead of bin path I am getting the same error.Is there issue if its not showing out there.

C:\Users\SOPHIAA>rsync --version
‘rsync’ is not recognized as an internal or external command,
operable program or batch file.

Hi @Sophia_78936,

I do not think this should create an issue.
Please proceed further with the course and if you get any errors, please let me know.