Rsync command - Error

Getting error as “‘rsync’ is not recognized as an internal or external command,
operable program or batch file.”

I followed all the steps correctly.But I am able to do for ssh but rsync is not working.
Using windows 10 64 bit.
I also tried pasting path in different line in environment variables.

Can anybody respond for this.I tried each and avery option already posted in forum.Still I am not able to get.

Did you install MinGW.Somewhere during install you have to check option rsync
What does rsync --version show at your command prompt
Below link may help

You can confirm that rsync and ssh are both successfully installed and accessible via your PATH by launching the command prompt (cmd) and running rsync and ssh respectively. Both commands should output usage information. If you receive an error about not being recognized as an internal or external command then you’ll need revisit the steps above

Hi Ramachandra…thanks for your reply.

i have installed MinGW and rsync option is enabled.I have the same path details.But still I am getting the error for rsync.
R1 R2 R3

Path: %USERPROFILE%\AppData\Local\Microsoft\WindowsApps;C:\MinGW\msys\1.0\bin;

Are you able to invoke rsync being at bin location?
cd to C:\MinGW\msys\1.0\bin
rsync --version
or try alternate method
export variable at session level and check

I tried from bin location in the command prompt and getting the below eeror.

Use “rsync --daemon --help” to see the daemon-mode command-line options.
Please see the rsync(1) and rsyncd.conf(5) man pages for full documentation.
See for updates, bug reports, and answers
rsync error: syntax or usage error (code 1) at /usr/src/rsync/rsync-3.0.8/main.c(1420) [client=3.0.8].