replSetReconfig force generate too high version number

When using db.adminCommand({replSerReconfig: {...}, force: true}) I got an error whatever version number I put in.

{
	"ok" : 0,
	"errmsg" : "BSON field 'version' value must be < 2147483648, actual value '2147529374'",
	"code" : 51024,
	"codeName" : "Location51024",
	"$clusterTime" : {
		"clusterTime" : Timestamp(1659450614, 1),
		"signature" : {
			"hash" : BinData(0,"LxJSIFgxTpIuQhwh+L1jRnFBzi8="),
			"keyId" : NumberLong("7124390870412951557")
		}
	},
	"operationTime" : Timestamp(1659450614, 1)
}

apparently force option will generate automatically an higher number but it seems that is not capped to a correct value ??

Any help is more than welcome :slight_smile:

A post was merged into an existing topic: Can I reset the version of the replSetConfig?