Replica Set Deployment Unsuccessful Test Results

Please can someone tell me what I’m getting wrong here: I added below 2 nodes as last past of lab tasks, I ran rs.status() to check that the members array has three nodes - only one was labeled PRIMARY and the output did show the other 2 secondary. Below are the test results, kindly advise…

rs.add(“m103-:27002”)
rs.add(“m103-:27003”)

12 total, 10 passed, 0 skipped:
[PASS] “localhost:27001 is running”
[PASS] “localhost:27002 is running”
[PASS] “localhost:27003 is running”
[PASS] “Replication is enabled on localhost:27001”
[PASS] “Replication is enabled on localhost:27002”
[PASS] “Replication is enabled on localhost:27003”
[PASS] “Replica set ‘m103-repl’ has the correct name”
[PASS] “The replica set ‘m103-repl’ contains localhost:27001”
[FAIL] “The replica set ‘m103-repl’ contains localhost:27002”
Did you add ‘localhost:27002’ to the replica set ‘m103-repl’?
[FAIL] “The replica set ‘m103-repl’ contains localhost:27003”
Did you add ‘localhost:27003’ to the replica set ‘m103-repl’?
[PASS] “The replica set enforces client authentication”
[PASS] “The replica set m103-repl uses keyfile authentication”

Add other 2 nodes with localhost:port

Thanks for the information, it worked when I added localhost:post

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.