Recurring sync error with message Bad changeset (DOWNLOAD)

Every day we are receiving sync errors with message Bad changeset (DOWNLOAD) when users try to login in our Realm App with custom JWT auth.

Our only option is to perform a “terminate sync” whenever this occurs.

We searched for the error message and found several reports of this sync issue here, but we couldn’t identify what could be causing this issue.

Our “client_max_offline_days” setting is set with 4 days, and the problem continues to occur every day, even if users uninstall the app and install it again, the error only goes away with “terminate sync”.


WARN ["Realm sync error", "realm-default", {"category": "realm::sync::ClientError", "code": 112, "isFatal": true, "message": "Bad changeset (DOWNLOAD)", "name": "Error", "userInfo": {}}]

WARN {"errorCode": 1, "message": "Bad changeset (DOWNLOAD)"}

We also tried to open a support ticket, but I think that the support page is down.

Hi @Douglas_Junior ,

The Bad Changeset (DOWNLOAD) error is something we should look into as Support, if you have a contract for that Project please open a case. The Support Portal seems to be working properly at the moment, the error you receive is about authentication, can you please double check you’re connected as the Project Owner?

Yes, I’m Organization Owner and Project Owner. I tried to enter with Google and with password too.

The “Support SSO Failure” occurs just after the login page.

I’ve even tried changing the browser :cry:

Would it be possible to initiate a Support ticket via email?

A found a “chat” button inside Atlas, I will try to open a ticket now.

Yes, that’s the right procedure, it should work.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.