Recurring log "saving checkpoint snapshot"

Starting a local dev instance with --quiet still emits a lot of redundant logs on the form

Sep 09 10:30:38Z split-serving/omnicoder-84f66bbf7-78vqw mongodb  {"t":{"$date":"2022-09-09T10:30:38.100+00:00"},"s":"I",  "c":"STORAGE",  "id":22430,   "ctx":"Checkpointer","msg":"WiredTiger message","attr":{"message":"[1662719438:100728][7:0x7f22cd832700], WT_SESSION.checkpoint: [WT_VERB_CHECKPOINT_PROGRESS] saving checkpoint snapshot min: 111, snapshot max: 111 snapshot count: 0, oldest timestamp: (0, 0) , meta checkpoint timestamp: (0, 0) base write gen: 1"}}

Since these are supposed to be informative only I would like to turn them off.

I only want logs about two things:

  1. on boot up on the configuration parameters used
  2. on warnings or errors during running the application

I do not want information of “everything is fine this is what I am doing right now”

–quiet does not turn this off. How can I turn it off?

~/Documents/GitHub/omnicoder/k8s master ≡
❯ docker run --rm mongo:5.0.9 --quiet --quiet
Error parsing command line:  Multiple occurrences of option "--quiet"
try 'mongod --help' for more information

~/Documents/GitHub/omnicoder/k8s master ≡
❯ docker run --rm mongo:5.0.9 --quiet=2
Error parsing command line: option '--quiet' does not take any arguments
try 'mongod --help' for more information

Hi @Henrik_Holst

I think what you’re looking for is changing the log verbosity setting. You can change this using the command db.setLogLevel() or set it in the config file.

Out of curiousity, the logs are supposed to help with troubleshooting since it records what the server is doing at what particular time. Most times, you don’t need to look at them (a lot of applications simply redirect them to a file), and if you’re interested in some part of it, you can filter out the rest of them. Is there a specific reason why you don’t want these informations to be recorded?

Best regards
Kevin