Realm Studio 3.11.0 upgrade causes incompatibility issues with Realm Pods

I was prompted to upgrade to v3.11.0 when launching Realm Studio v3.10.0 today.

On doing so, the initial issue I faced was that the Realm I was testing in Xcode could not be opened simultaneously by Studio - the error message displayed was “Realm file is currently open in another process which cannot share access with this process. All processes sharing a single file must be the same architecture.”

I closed Xcode & Simulator and opened the Realm file in Studio 3.11.0 only. This notified me that the Realm file was from an earlier version and prompted me to allow update, which I did so.

However, the updated Realm file no longer works with the Realm pods installed via CocoaPods. The version of Realm & RealmSwift I have is 4.4.1. I ran pod deintegrate, install and update and still get the same version.

Pod outdated gives the following message
The following pod updates are available

  • Realm 4.4.1 -> 4.4.1 (latest version 10.0.0-alpha.4)
  • RealmSwift 4.4.1 -> 4.4.1 (latest version 10.0.0-alpha.4)
    however the version is marked - Will not because of specified version in Podfile. I have not specified the version in my Podfile.

The only resolution currently is to uninstall 3.11.0 and reinstall 3.10.0.

@Richard_English Correct - you should downgrade if you are intending to use RealmSwift 4.4.1

The new version of Studio is designed to work with RealmSwift 5.0 which we are hoping to GA on the 18th.

See the Studio Release notes here:

Thanks, although please note 10.0.0-alpha.4 does not work with Realm Studio 3.11.0 either. The only configuration which is working for me is Realm Studio 3.10.0 with RealmSwift 4.4.1.

Hopefully RealmSwift 5.0 remedies this.