Realm Functions timeout after 10 seconds (Android)

I already filed an issue on github, but there has been no reaction yet: https://github.com/realm/realm-java/issues/7455

When I call a function from within my android application, which takes longer then 10 seconds, I run into a timeout error. On the server I get the following Error: operation canceled

The function works fine, when I call it from the server and even when I call it from the iOS App!

I tried to change the timeout with no luck:
AppConfiguration.Builder(APP_ID)
.requestTimeout(90000, TimeUnit.MILLISECONDS)
.build()

I would really appreciate if someone could have a look at it!

Hi Annika,

I’d suggest upvoting this request, and add a comment to it describing your scenario: Increase of Functions timeout – MongoDB Feedback Engine

Hi Andrew,

I already upvoted this request. However, in my case, the 90 seconds timeout is not the issue as my function takes roughly 40 seconds to execute. I can run the function with no limitations from the server and the iOS App (realm-cocoa).

I guess the problem lies either within the realm-java sdk or on my end somewhere. Would be nice if someone could try to reproduce the error by calling a function that takes longer than 10 seconds with realm-java.

@Mohit_Sharma – is this something you could try to reproduce?

@Andrew_Morgan : I have already raised this issue with the concerned team and waiting response.