Realm-dot-net Bad changeset (DOWNLOAD)

Hi there.

I’m banging my head against the wall here - i simply cannot figure out why im getting this error:
Code 112
“Bad changeset (DOWNLOAD)”

I’ve tried with realm 10.0.0 beta2 - 10.0.0 beta6, but it’s the same for all versions.
It worked earlier today, and after minor changes to my models it did not. I’ve tried reverting to the earlier models, deleting database, uninstalling app and cleaning build folders - but the result is the same.

The only log statement in cloud that indicates an error, is:
invalid session

I’m not getting this anymore, and no new errors are showing - only succesful requests.

Any ideas what might be wrong?

@Rasmus_B Can you upgrade to beta.6, wipe your client, terminate and re-enable sync on the cloud portal and see if you can reproduce? If you still run into it please open a case with support

Hi Ion.
Thanks for the reply. I already tried beta.6, but it made no difference.
I will try to contact support.

Did you ever get this resolved? I have one Realm that gets the same error. Have tried deleting the local instance then running again but no change. This only started recently and all the other realms are opened without incident.

Not as far as i remember, i think the problem just went away by itself after some time…